FireFox 6 – Don’t!

If you are one of the fortunate people who is still using FireFox 5, or possibly still using FireFox 3.6.x – ignore the repeated requests to upgrade to FireFox 6!  Stay put.  FireFox 5 was a perfectly stable platform.  FireFox 6 hangs nearly as often as FireFox 4, and there are incompatibility problems with several of my favorite plugins.  I save install executables and I’m seriously considering uninstalling 6 and reinstalling 5.

This entry was posted in Technical. Bookmark the permalink.

1 Response to FireFox 6 – Don’t!

  1. hedera says:

    OK, they seem to have fixed the problem with the .01 and .02 upgrades. I’m still annoyed with them.

Leave a Reply to hedera Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.